Advanced Excel Tips and Tricks

Presented by
Ivan L. Hemmans, III

OM13
4/3/2017
1:45 PM - 3:15 PM

The handouts and presentations attached are copyright and trademark protected and provided for individual use only.
Accessing all the functions in Excel

Excel contains a vast array of functions you can use to perform various calculations. You can use Insert Function to become familiar with the functions available in Excel and to become familiar with what each of the functions does.

Use Insert Function to insert a function you choose into an empty cell. You can search for a function by keyword or by category.

To launch the Insert Function dialog box

1. Select the empty cell where you want the function to be stored.
2. Click Formulas > Insert Function.
   
   The Insert Function dialog box appears. [Figure at right]
3. In the Search for a function box, type a description of the function you want.

Note: Alternatively, you can use the category dropdown list to see functions that all relate to a certain type of calculation like “Lookup & Reference.”
4. In the **Select a function** area, click to select a function.

   **Note:** Excel displays a description of the selected function below the **Select a function** area.

5. Click **OK**.

6. In the **Function Arguments dialog box**, click in an argument box. [Figure 2]

![Figure 2]

   **Note:** Excel displays a description for the argument that corresponds to selected box.

   If you have chosen a function that requires more than one argument, you can see descriptions for all required arguments by clicking in each of the boxes.

### Removing extra spaces from cells

If you have data that contains additional spaces, there is a function you can use to trim them out.

**To remove extra spaces from data:**

1. Select a destination cell for your formula.
2. Type `=trim([cell name])`, then press **Enter**.

   **Note:** According to Excel’s Insert Function dialog box, Trim removes all spaces from a text string except for a single space between words.
**Paste the resulting values, not the formula**

Occasionally, you may need to use a formula to change the way data appears. And, it is often handy to be able to extract the resulting value of a formula, but not the formula itself.

For example, you can use a formula to remove extra spaces from data. If you then wanted to split the resulting values across columns, you would need to extract the values because you can only split text across columns, not formulas.

**To paste values**

1. Select the cell(s) containing the formula(s).
2. Press **CTRL+C** to copy.
3. With the cell still selected, on the **Home** tab, click the arrow beneath **Paste**, and then the first icon in the **Paste Values** area - **Paste Values**.

**Note:** You can paste the resulting values over the original data to “change” it, or you can select different destination cells to contain the plain text.

The steps above describe how to replace the formulas with corresponding values.

**Distributing data across columns**

In Excel, you can take a cell and split its text across columns in a number of ways. The easiest of these is to use the **Text to Columns** command on the **Data** tab.

For example, if you have a cell that contain both first and last names, you can use the **Text to Columns** command to split the data in each cell across multiple columns using a **delimiter**, a special character that indicates at what point data should be split. In this example, we will use a space as the delimiter.

**To split text in a cell across columns:**

1. Select the cells you wish to affect. [Figure 3]
2. On the **Data** tab, in the **Data** Tools group, click **Text to Columns**.
3. In the Wizard, select **Delimiter**, then click **Next**.
4. In the **Delimiters** area, check **Space**, then click **Finish**. [Figure 4]
Note: In this example, a new Column C was inserted prior to beginning the steps to split the cell data. The result of using the *Text to Columns* command is that the split data is saved into cells to the right of the original cell. If any preexisting data is in danger of being overwritten Excel warns you and gives you an opportunity to cancel.

Combining data from multiple cells

As you might imagine, Excel also gives you the ability to combine text from multiple cells into a single destination cell.

For example, if you have a cell that contains a first name and another cell that contains a last name, you can combine those cells together and also include arbitrary strings of characters such as a spaces (" "), or comma space (", "), or even whole words or phrases.

**To combine text from multiple cells:**

1. Select the empty cell where you want the function to be stored.
2. Click the **Formula** button (Fx) on the Formula bar.
3. In the **Category** dropdown list, select **Text**.
4. In the **Function** area, select **Concatenate**, then click **Enter**. [Figure 5]
5. Select **Text1** in the Concatenate dialog box, then either click a cell on the sheet or type some text.
6. Select **Text2** in the Concatenate dialog box, then either click a cell on the sheet or type some text. [Figure 6]
7. Repeat steps 5 and 6 as necessary, then click **OK**.
Use the Lookup feature to find values in lists

You can use VLOOKUP or HLOOKUP to find corresponding information in a list of data, either vertically (VLOOKUP) or horizontally (HLOOKUP).

The VLOOKUP function scans vertically down the leftmost column of data, looking for a match to the input you provide. Upon finding a match, VLOOKUP returns a value from the given row, corresponding to a column you specify.

HLOOKUP functions similarly, but it scans horizontally across the first row of data and returns a value from a given column, with respect to a corresponding row number.

For example, if your data looks like the data in Figure 7 below, then this formula, \( =\text{VLOOKUP("associate"}, A1:B4, 2) \), would return 135:

\[
\begin{array}{|c|c|}
\hline
A & B \\
1 & Associate & 135 \\
2 & Employee & 45 \\
3 & Partner & 360 \\
4 & Trainer & 30 \\
\hline
\end{array}
\]

The three arguments required by VLOOKUP are **Lookup Value**, **Table Array**, and **Column index**. There is an optional fourth argument, **Range Lookup**.

- **Lookup Value**: The data you want to find. This can be text (enclosed in quotes) or it can be a reference to another cell.
- **Table Array**: A reference to a range of cells of at least 1 column of data. By default, the first column of data is used as the index to find the corresponding data for each row. Your data should be sorted in ascending order by the first column.

- **Column Index**: The corresponding column that contains the data you want to return.

- **Range Lookup** [optional]: A logical value, TRUE or FALSE. If this argument is omitted or TRUE the lookup returns the first closest match. If the argument is set to FALSE, lookup searches for an exact match.

**Note**: If you plan to copy your formula to use across more than one cell, you may wish to use absolute cell references for the table array so the addresses do not automatically adjust to a new range as the formula is copied. In our above example, the **Table Array** reference would become $A$1:$B$4.

**Set up reliable data validation**

You can use data validation to restrict the type of information allowed in a given cell (or cells). You can also specify a range of valid data for numerical, time or date values, and even text length. In addition, you can use data validation to limit data to a predefined list of acceptable items.
To set up data validation:
1. Select the cells you wish to affect. [Figure 8]
2. Click Data, Validation.
   The Data Validation dialog box appears.
3. On the Settings tab, in the Allow box, click List.
4. In the Source box, type the values, separated by commas, you want to allow.
   For example, try typing: blue, green, orange. [Figure 9]
5. Click OK.
   When you click on a cell, the drop-down arrow is available with the values you specified. [Figure 10]

Note: In Outlook 2007, click the Data tab, then click Data Validation.

Note: In the Source box, you can use a formula or reference to a range of cells that contain your list values rather than explicitly typing those values in.
   However, if you want to refer to a range of cells on a different worksheet in the same workbook, you need to define a named range, then refer to the named range in the Source box, =named_range.

Tip: You can use the Input Message and Error Alert tabs to set up user-friendly feedback to explain the nature of the data to be entered and to prompt the editor of the workbook to enter correct data.
Group, filter and total large lists of data

If you are working with a large list of data, or even if your list isn’t so large, you can group related items together as a Table in Excel. Once grouped, Excel enables a small collection of features designed to make managing your list easier.

**Note:** Every table you insert has a unique name. Selecting meaningful table names makes formulas that reference them easier to follow. Find the table name in the contextual Table Tools ribbon, on the **Design** tab.

Insert a Table

The steps below outline how to add a List to your workbook.

**To insert an Excel Table:**

1. Select the cells you want to include in the List.

**Note:** If the data on your sheet contains no blank rows or columns, you can select a single cell containing data, rather than the entire range.

2. Click **Insert > Table**.

3. If your list has a header row, ensure the **My List Has Headers** checkbox is checked.

4. Click **OK**.

![Figure 11](image-url)
Features of an Excel List

Every Excel Table has several prominent features, which can be used to manage large lists of data.

1. AutoFilter: You can use AutoFilter to filter or sort your list.
2. Ledger lines. Actually, these are Table Styles to help make table data easier to see.
3. Insert Row: At the bottom of the table, when you add new data, the list grows to accommodate it.
4. Total Row: When this row is enabled, you can select from several predefined functions to calculate results for a given column.

**Note:** In Excel 2003, on the List toolbar, click **Toggle Total Row** to enable or disable the total row. In Excel 2007, check **Total Row** in the **Table Style Options** group. The total row is off by default.

The total row functions work in combination with AutoFilter, so that only visible items are included in the calculation results.

5. Resize Handle: Drag the handle horizontally or vertically to include new columns or rows in the list range.
6. Table Tools: The Table Tools ribbon includes a number of formatting and options to get the most from the table, including Total Row, which can tabulate column totals automatically based on visible column data.

Benefits of using an Excel Table

There are several benefits you get by using Excel Tables:

1. The formatting of the last row is automatically carried forward when you add a new row.
2. Any formulas contained in the last row are automatically copied to new rows you add.
3. Charts and Pivot tables that refer to Lists are “aware” when you add or delete rows and adjust the range they refer to automatically.
4. When sorting, Excel will prevent you from leaving part of your list unsorted.

Convert a list back to a regular range

You can convert your list back to a regular range of cells by clicking the **Design** tab, then, in the **Tools** group, click **Convert to Range**.
Inserting charts or graphs

Microsoft uses the word “charts,” however many will see them and think “graphs.” Regardless of the word you choose to describe them, they help to represent numerical data in a visual way. A picture can often illustrate relationships that raw numbers may not.

In Microsoft Excel 2007 and later, click Insert > Chart. You may find it helpful to select the data you wish to visualize before attempting to insert a chart into your workbook.

When you select a chart in an Excel workbook, a contextual Chart Tools ribbon will appear. The ribbon includes a Design tab, which allows you to control how the chart looks, and a Format tab that allows you to arrange, annotate, or format the color of chart elements.

To insert an Excel Chart:

1. Select the cells you want to include in the chart.

   **Note:** If the data on your sheet contains no blank rows or columns, you can select a single cell containing data, rather than the entire range.

2. Click Insert > Chart. (Depending on your version of Excel, you may see an option to insert Recommended Charts.)

3. Select the type of chart you wish to insert, then click OK.
Helpful tools on the Chart Tools Design tab

- **Add Chart Element.** This tool allows you to add titles, data labels, legends and more.
- **Quick Layout.** This tool contains a collection of pre-configured combinations of chart elements.
- **Change Colors.** This tool contains a collection of different color palettes you can apply to your chart.
- **Switch Row/Column.** This tool allows you to set the chart to interpret a data series either horizontally or vertically.
- **Select Data.** This tool allows you to redefine the range of cells that the chart includes.
- **Change Chart Type.** You can guess the function of this tool by its name.
- **Move Chart.** By default, charts are inserted as floating objects on a given worksheet. This tool allows you to move a chart to a different worksheet or set the chart to be its own worksheet within the workbook.

Working with PivotTables

Excel is arranged in rows and columns. Arranging your data in rows and columns — or columns and rows — will help you when it’s time to run reports.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>% Paralegal Time to Total Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2004</td>
<td>Corporate Client B, Ltd.</td>
<td>14-03023-ROR</td>
<td>Comm- Lead</td>
<td>Electronic Discovery &amp; Doc Retention</td>
<td>1-May-04</td>
<td>30-Apr-04</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>2004</td>
<td>Corporate Client A, Inc.</td>
<td>04-11025-MRN</td>
<td>Comm- Lead</td>
<td>Class Action Defense</td>
<td>1-Nov-04</td>
<td>30-Nov-04</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>2004</td>
<td>Corporate Client A, Inc.</td>
<td>01-11623-MRN</td>
<td>Comm- Lead</td>
<td>Class Action Defense</td>
<td>1-Oct-04</td>
<td>31-Dec-04</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>2004</td>
<td>Corporate Client B, Ltd.</td>
<td>14-03023-ROR</td>
<td>Comm- Lead</td>
<td>Electronic Discovery &amp; Doc Retention</td>
<td>30-Dec-02</td>
<td>31-Dec-04</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>2004</td>
<td>Corporate Client A, Inc.</td>
<td>04-11025-MRN</td>
<td>Comm- Lead</td>
<td>Class Action Defense</td>
<td>1-Oct-04</td>
<td>30-Nov-04</td>
<td>5%</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>2004</td>
<td>Corporate Client C</td>
<td>05-29456-BPV</td>
<td>Comm- Lead</td>
<td>Global Enforcement &amp; Civil Def</td>
<td>1-Feb-04</td>
<td>26-Feb-05</td>
<td>10%</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>2004</td>
<td>Corporate Client C</td>
<td>14-03023-ROR</td>
<td>Comm- Lead</td>
<td>Electronic Discovery &amp; Doc Retention</td>
<td>1-Jun-04</td>
<td>30-Jun-04</td>
<td>10%</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>2004</td>
<td>Corporate Client C</td>
<td>14-03023-ROR</td>
<td>Comm- Lead</td>
<td>Electronic Discovery &amp; Doc Retention</td>
<td>1-May-04</td>
<td>31-May-04</td>
<td>12%</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>2004</td>
<td>Corporate Client A, Inc.</td>
<td>04-11025-MRN</td>
<td>Comm- Lead</td>
<td>Class Action Defense</td>
<td>1-Dec-04</td>
<td>31-Dec-04</td>
<td>12%</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>2004</td>
<td>Corporate Client C</td>
<td>05-29456-BPV</td>
<td>Comm- Lead</td>
<td>Global Enforcement &amp; Civil Def</td>
<td>1-Feb-04</td>
<td>26-Feb-04</td>
<td>10%</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>2004</td>
<td>Corporate Client C</td>
<td>14-03023-ROR</td>
<td>Comm- Lead</td>
<td>Electronic Discovery &amp; Doc Retention</td>
<td>1-Feb-04</td>
<td>26-Feb-04</td>
<td>10%</td>
<td></td>
</tr>
</tbody>
</table>

Each row should be dedicated to a single item in your list. For example, if your spreadsheet contains an employee list, then each row could be dedicated to a single employee. Each column should be dedicated to a single attribute of the row item. Column “A” could be dedicated to the employee’s “Name” and column “B” could be dedicated to the employee’s “Title.” So, row 7’s “A” column might refer to “Anna” and the “B” column might say “CEO,” while row 8’s “A” column might refer to “Kyle” and the “B” column might say “Associate.”

In the screenshot above, Column “A” is dedicated to “Year,” Column “B” is “Case,” Column “C” is “Case#,” etc.

If you need to track additional attributes, just add another column of data to your spreadsheet.
Note: Try to avoid combining multiple types of data into the same cells, like “phone number” and “office.” Having more columns of data will allow you more ways to sort, filter, and calculate.

Tip: In addition, avoid blank rows and columns. Most people include blank rows or columns to make spreadsheets easier to read. For readability, consider adjusting row height or column width instead. Excel treats data on the other side of a blank row or column as unrelated information and will not automatically select it when you sort.

Create a PivotTable
A PivotTable is a reporting tool you can use to analyze data. With a PivotTable, you can create totals and subtotals. In addition, you can compare the totals of one column to another.
You can “pivot” the data in this kind of report to display it vertically or horizontally.

To create a PivotTable report
1. Select the range of data you wish to include in the report.

Note: If the range of data on your worksheet contains neither blank rows nor columns, you can skip this step.

2. On the Insert tab, PivotTable, then click OK.
   A new PivotTable appears on a new worksheet named Sheet 1.
3. Rename Sheet 1 as Pivot.
Anatomy of the Pivot Table

A PivotTable consists of 4 areas, the Report Filter, Column Labels, Row Labels, and Values.

- **Row Labels**: When you drag a field into this area, Excel creates a list of unique values found and displays each as its own row.

- **Column Labels**: When you drag a field into this area, Excel creates a list of unique values found and displays each as its own column.

- **Values**: When you drag a field into this area, Excel sums or counts the items according to the groupings within the Row or Column Labelss.

- **Report Filter**: When you drag a field into this area, Excel creates a top-level filter to control which data is displayed in the PivotTable.

- **PivotTable Field List**: The field list displays a list of all the column headers from the worksheet to which the PivotTable is linked.

- **PivotTable Tools**: A ribbon appears with tabs for controlling Options and Design.

**Note**: You can use the PivotTable Tools to adjust the options and display settings for the PivotTable.
Drag Fields onto a PivotTable

1. In the Field List, drag Practice Group and drop it in the Row Labels.
   Across the 104 rows of data, Excel displays the 8 unique practice group values it found — each value in its own row.

2. In the Field List, drag Paralegal Fees into the Values.
   Excel sums the paralegal fees within each of the Practice Group rows.

Pivot the Table

1. In the PivotTable, drag the Practice Group heading and drag it to the Column Labels.
   Excel displays each of the 8 practice groups as its own column.

2. Drag the Practice Group heading back to the Row Labels.

Add a Field to the Column Labels

Until now we have been dragging items into the various areas of the PivotTable. You can also “zap” items directly to the appropriate area of the PivotTable by selecting a field and clicking the button beneath the Field List.

1. Right-click on Year, in the Field List.

2. Click Add to Column Labels.

**Note:** When you have both a row field and a column field, Excel shows a cross-section of your data.

Add another column to the Data Area

You can summarize more than one column of information at a time in a PivotTable.

1. In the Field List, drag Attorney Fees and drop it in the Data Area.

2. Look at the Data Area to see totals of Paralegal Fees next to Atty Fees.

3. Look for a Data Label in either the Row Labels or Column Labels.

**Note:** When a PivotTable has more than one column or “field” in the Data Area, it creates a “Values” label and groups totals under it. You can drag the Data label to the Row Labels to display totals as stacked rows, or to the Column Labels to display as side-by-side columns.
Control Which Data is Displayed
You can control which row or column values are displayed. Excel calculates totals based on which row or column values are visible.

1. Click the dropdown arrow next to Practice Group.
2. Uncheck Environmental Law & Natural Res.
3. Uncheck Global Enforcement & Criminal Def, then click OK.
   Excel hides those rows and their totals.

Format Data
You can control the format of data displayed in the data areas.

1. Select a cell in the data area.
2. On the Options tab, in the Active Field group, click Field Settings.
   
   Note: You can rename this field, change the formula summing your data to something else, like Average or Count. You can also change the format of the number.

3. Click the Number Format button.
4. Click Accounting, then click OK.
   Excel displays the Paralegal Fees totals as dollar amounts.
5. Repeat these steps for Atty Fees.

Subtotals in a Table
You can stack fields within the Row or Column Labels to create subtotals. Within an area, fields to the right are subtotaled under fields to the left.

1. In the Field List, Select Role.
2. Drag it as the top items in Row Labels.
   
   Note: Excel takes the Practice Groups and subtotals them under Role.

Remove a Field from the PivotTable

1. Select the Role field heading in the Row Labels.
2. Click PivotTable menu, then click Hide.
   
   Note: Alternatively, you can drag the field heading outside the range of the PivotTable.
Filter with a Page Field

1. In the Field List, drag Case to the Report Filters.
2. In the Report Filters, click the dropdown arrow next to Case.
3. Click Corporate Client A, Inc., then click OK.
   Excel displays all data pertaining to Client A.
4. Click the dropdown arrow again, then click Corporate Client B, Ltd., then click OK.
   Excel displays all data pertaining to Client B.
5. Click the dropdown arrow again, then select All, and then click OK.

Note: You can create separate pages for each page field.
On the Options tab, in the PivotTable group, click Options,
then Show Report Filter Pages.

Drilling Down

After you have created a PivotTable, you might want to know where a particular total is coming from. Excel lets you drill into a particular total to see what rows of data comprise the total.

1. Filter the PivotTable by Corporate Client A.
2. Double-click the value that corresponds to Adversarial Practice Group for year 2004.

Note: Excel creates a new worksheet named something like “Sheet 5” and populates it with a copy of the rows from your source data that contribute to the total on your PivotTable.
Once you have viewed the data, you can safely delete the new worksheet without damaging your workbook.

3. Delete the newly created worksheet.

Important Things to Know About PivotTables

Refresh Your PivotTable: By default, PivotTables do not automatically refresh when you change information on the data worksheet.
On the Options tab, click Refresh.

Note: You can set the PivotTable options to “Refresh data when opening the file.”

Format Your PivotTable: The default formatting of PivotTables in Excel is plain. You can spruce up your report with one of the built-in format.
Click the **Design** tab, then choose one of the **PivotTable Styles**.

**Note:** The first formatting option will revert formatting to the default.

**General Excel Tips**

- **Adjust screen zoom with CTRL + Scroll.** If you have a mouse with a scroll wheel, you can adjust the zoom level by pressing and holding the CTRL key, then scrolling the wheel.

- **CTRL + Shift + Arrow.** You can use this key combination to highlight a range of cells along the same row or within the same column. The Shift key is what triggers the highlighting. You can navigate the spreadsheet quickly by omitting Shift from this shortcut.

- **Automatically fill a series with a “double-click.”** When you select a cell, you can automatically copy its contents down the column as far as the adjacent column of data goes. Double-click the AutoFill handle.

- **Press CTRL + ` to toggle the display of formulas.** You can toggle the display of formulas in a workbook, either by going into Excel’s Advanced options or by pressing a keyboard shortcut. With the formulas displayed, it is much easier to see which cells contain formulas in use throughout the workbook. Press CTRL + ` again to hide the formulas and display their results once more.
Your opinion matters!
Please take a moment now to evaluate this session.

Thank You!